• 给员工放“世界杯假”,靠谱吗?--旅游频道 2019-10-15
  • 深圳交出亮丽“民生答卷”(壮阔东方潮 奋进新时代——庆祝改革开放40年) 2019-10-15
  • 年终奖PK大赛来袭 网友:心疼得抱住自己 2019-10-14
  • 岗集金明花园小区问题多 希望能改造和加强管理 2019-10-14
  • “悬”在山腰上的火车站:春运我们24小时待命 2019-10-10
  • 次平:年楚河的守护者 2019-10-10
  • 人民网评:汶川大地震十年,那些不能忘却的记忆 2019-09-21
  • 海南 求贤若渴 人才公寓免 8 年租金 到期赠与 100% 产权 ——凤凰网房产深圳 2019-09-21
  • Народ является создателем истории и настоящим героем -- Си Цзиньпин 2019-09-15
  • 【理上网来·辉煌十九大】欧莱雅公司董事长:中国是推动世界创新发展的主要动力 2019-09-13
  • 梦参老和尚:相信众生都可度 只是我的德不够 2019-09-10
  • 南昌婴儿安全岛何时开放 2019-09-09
  • 意见反馈中国国家地理网 2019-09-09
  • 马钢与十七冶签订战略合作框架协议 2019-09-07
  • 铁岭市妇联:百合家事促家事百和 2019-09-03
  • 香港2013马会特码资料:CCNA实验:全面的三层交换机配置实例

    CISCO认证考试网 鲤鱼小编 更新时间:2019-02-20

    比较全面的三层交换机配置实例(带命令解释哟!)

    Enable //进入私有模式

    Configure terminal //进入全局模式

    service password-encryption //对密码进行加密

    hostname Catalyst 3550-12T1 //给三层交换机定义名称

    enable password 123456. //enable密码

    Enable secret 654321 //enable的加密密码(应该是乱码而不是654321这样)

    Ip subnet-zero //允许使用全0子网(默认都是打开的)

    Ip name-server 172.16.8.1 172.16.8.2 //三层交换机名字Catalyst 3550-12T1对应的IP地址是172.16.8.1

    Service dhcp //提供DHCP服务

    ip routing //启用三层交换机上的路由???/span>

    Exit

    Vtp mode server //定义VTP工作模式为sever模式

    Vtp domain centervtp //定义VTP域的名称为centervtp

    Vlan 2 name vlan2 //定义vlan并给vlan取名(如果不取名的话,vlan2的名字应该是vlan002

    Vlan 3 name vlan3

    Vlan 4 name vlan4

    Vlan 5 name vlan5

    Vlan 6 name vlan6

    Vlan 7 name vlan7

    Vlan 8 name vlan8

    Vlan 9 name vlan9

    Exit

    interface Port-channel 1 //进入虚拟的以太通道组1

    switchport trunk encapsulation dot1q //给这个接口的trunk封装为802.1Q的帧格式

    switchport mode trunk //定义这个接口的工作模式为trunk

    switchport trunk allowed vlan all //在这个trunk上允许所有的vlan通过

    Interface gigabitethernet 0/1 //进入???/span>0上的吉比特以太口1

    switchport trunk encapsulation dotlq //给这个接口的trunk封装为802.1Q的帧格式

    switchport mode trunk //定义这个接口的工作模式为trunk

    switchport trunk allowed vlan all //在这个trunk上允许所有的vlan通过

    channel-group 1 mode on //把这个接口放到快速以太通道组1

    Interface gigabitethernet 0/2 //同上

    switchport trunk encapsulation dotlq

    switchport mode trunk

    switchport trunk allowed vlan all

    channel-group 1 mode on

    port-channel load-balance src-dst-ip //定义快速以太通道组的负载均衡方式(依*源和目的IP的方式)

    interface gigabitethernet 0/3 //进入???/span>0上的吉比特以太口3

    switchport trunk encapsulation dotlq //trunk封装为802.1Q


    switchport mode trunk //定义这个接口的工作模式为trunk

    switchport trunk allowed vlan all //允许所有vlan信息通过

    interface gigabitethernet 0/4 //同上

    switchport trunk encapsulation dotlq

    switchport mode trunk

    switchport trunk allowed vlan all

    interface gigbitethernet 0/5 //同上

    switchport trunk encapsulation dotlq

    switchport mode trunk

    switchport trunk allowed vlan all

    interface gigbitethernet 0/6 //同上

    switchport trunk encapsulation dotlq

    switchport mode trunk

    switchprot trunk allowed vlan all

    interface gigbitethernet 0/7 //进入???/span>0上的吉比特以太口7

    Switchport mode access //定义这个接口的工作模式为访问模式

    switchport access vlan 9 //定义这个接口可以访问哪个vlan(实际就是分配这个接口到vlan

    no shutdown

    spanning-tree vlan 6-9 cost 1000 //在生成树中,vlan6-9的开销定义为10000

    interface range gigabitethernet 0/8 10 //进入???/span>0上的吉比特以太口8,9,10

    switchport mode access //定义这些接口的工作模式为访问模式

    switchport access vlan 8 //把这些接口都分配到vlan8

    no shutdown

    spanning-tree portfast //在这些接口上使用portfast(使用portfast以后,在生成树的时候不参加运算,直接成为转发状态)

    interface gigabitethernet 0/11 //进入???/span>0上的吉比特以太口11

    switchport trunk encapsulation dotlq //给这个接口封装为802.1Q

    switchport mode trunk //定义这个接口的工作模式为trunk

    switchport trunk allowed vlan all //允许所有vlan信息通过

    interface gigabitethernet 0/12 //同上

    switchport trunk encapsulation dotlq

    switchport mode trunk

    switchport trunk allowed vlan all

    interface vlan 1 //进入vlan1的逻辑接口(不是物理接口,用来给vlan做路由用)

    ip address 172.16.1.7 255.255.255.0 //配置IP地址和子网掩码

     

    standby 1 ip 172.16.1.9 //开启了冗余热备份(HSRP),冗余热备份组1,虚拟路由器的IP地址为172.16.1.9

    standby 1 priority 110 preempt //定义这个三层交换机在冗余热备份组1中的优先级为110,preempt是用来开启抢占模式

    interface vlan 2 //同上

    ip address 172.16.2.252 255.255.255.0

    no shutdown

    standby 2 ip 172.16.2.254

    standby 2 priority 110 preempt

    ip access-group 101 in //在入方向上使用扩展的访问控制列表101

    interface vlan 3 //同上

    ip address 172.16.3.252 255.255.255.0

    no shutdown

    standby 3 ip 172.16.3.254

    standby 3 priority 110 preempt

    ip access-group 101 in

    interface vlan 4 //同上

    ip address 172.16.4.252 255.255.255.0

    no shutdown

    standby 4 ip 172.16.4.254

    standby 4 priority 110 preempt

    ip access-group 101 in

    interface vlan 5

    ip address 172.16.5.252 255.255.255.0

    no shutdown

    standby 5 ip 172.16.5.254

    standby 5 priority 110 preempt

    ip access-group 101 in

    interface vlan 6

    ip address 172.16.6.252 255.255.255.0

    no shutdown

    standby 6 ip 172.16.6.254

    standby 6 priority 100 preempt

    interface vlan 7

    ip address 172.16.7.252 255.255.255.0

    no shutdown

    standby 7 ip 172.16.7.254

    standby 7 priority 100 preempt

    interface vlan 8

    ip address 172.16.8.252 255.255.255.0

    no shutdown

    standby 8 ip 172.16.8.254

    standby 8 priority 100 preempt

    interface vlan 9

    ip address 172.16.9.252 255.255.255.0

    no shutdown

    standby 9 ip 172.16.9.254

    standby 9 priority 100 preempt

    access-list 101 deny ip any 172.16.7.0 0.0.0.255 //扩展的访问控制列表101

    access-list 101 permit ip any any

    Interface vlan 1 //进入vlan1这个逻辑接口

    Ip helper-address 172.16.8.1 //可以转发广播(helperaddress的作用就是把广播转化为单播,然后发向172.16.8.1

    Interface vlan 2

    Ip helper-address 172.16.8.1

    Interface vlan 3

    ip helper-address 172.16.8.1

    interface vlan 4

    ip helper-address 172.16.8.1

    interface vlan 5

    ip helper-address 172.16.8.1

    interface vlan 6

    ip helper-address 172.16.8.1

    interface vlan 7

    ip helper-address 172.16.8.1

    interface vlan 9

    ip helper-address 172.16.8.1

    router rip //启用路由协议RIP

    version 2 //使用的是RIPv2,如果没有这句,则是使用RIPv1

    network 172.16.0.0 //宣告直连的网段

    exit

    ip route 0.0.0.0 0.0.0.0 172.16.9.250 //缺省路由,所有在路由表中没有办法匹配的数据包,都发向下一跳地址为172.16.9.250这个路由器

    line con 0

    line aux 0

    line vty 0 15 //telnet线路(路由器只有5个,是0-4

    password 12345678 //login密码

    login

    end

    copy running-config startup-config 保存配置

    相关推荐:

    从四个方面来看MCSE与CCNA的差异

  • 给员工放“世界杯假”,靠谱吗?--旅游频道 2019-10-15
  • 深圳交出亮丽“民生答卷”(壮阔东方潮 奋进新时代——庆祝改革开放40年) 2019-10-15
  • 年终奖PK大赛来袭 网友:心疼得抱住自己 2019-10-14
  • 岗集金明花园小区问题多 希望能改造和加强管理 2019-10-14
  • “悬”在山腰上的火车站:春运我们24小时待命 2019-10-10
  • 次平:年楚河的守护者 2019-10-10
  • 人民网评:汶川大地震十年,那些不能忘却的记忆 2019-09-21
  • 海南 求贤若渴 人才公寓免 8 年租金 到期赠与 100% 产权 ——凤凰网房产深圳 2019-09-21
  • Народ является создателем истории и настоящим героем -- Си Цзиньпин 2019-09-15
  • 【理上网来·辉煌十九大】欧莱雅公司董事长:中国是推动世界创新发展的主要动力 2019-09-13
  • 梦参老和尚:相信众生都可度 只是我的德不够 2019-09-10
  • 南昌婴儿安全岛何时开放 2019-09-09
  • 意见反馈中国国家地理网 2019-09-09
  • 马钢与十七冶签订战略合作框架协议 2019-09-07
  • 铁岭市妇联:百合家事促家事百和 2019-09-03
  • 球探体育网球比分 3d两期无重复号技巧 最新pt游戏平台 重庆实时彩开奖结果 重庆时时开奖结果记录 双色球为什么中不了 必中计划软件免费版 澳洲幸运5破解软件 时时彩赚钱 快三玩法中奖技巧